Welcome to AddressOf.com Sign in | Join | Help

Adventures in Windows Vista (x64) - Part 1

I installed Windows Vista Ultimate (x64) last night and everything went pretty smoothly.  This, of course, is on the second machine I have on my desk so I can see what works (and doesn't) before making the full jump on the main machine. 

Out Of The Box Experience

After the installation and major Windows Update updates, the only thing not working out of the box was my sound card.  I don't know if it was because I technically had two different sound cards in the box, but Windows seemed to detect the on-board audio and suggested that I download and install the driver from the Windows Update process.  Going there, there is no driver listed. :-(  Anyway, I have a Audigy 4 in the box and Creative had a released driver available.  Works great thus far.

Software Compatibility

Installed Stardock Central so it could download and install Multiplicity.  The keyboard/mouse functionality of Multiplicity is working just fine, however, the copy/paste feature doesn't appear to work.  Not to big of a deal since I mainly use Multiplicity for the keyboard/mouse sharing. Everything works great (after enabling the "Enable clipboard sharing" option).

The install of Windows Live Messenger worked great (as one would hope/expect given it's from Microsoft as well).

Software Development "Issues" 

XboxFriends for the Desktop.  Houston, we have a problem.  Unfortunately, it's not with the XboxFriends application, rather an issue with Internet Explorer 7 combined with UAC and Adobe's lack of having a 64-bit Flash version.  So every time XBF browses to a Flash enabled page, the add-in installer kicks in causing the UAC prompt to ask if you'd like to continue.  Since there's no add-in available (due to Adobe not having one), this happens every time.  The issue is that, by default, that .NET 2.0 applications are compiled to be bit neutral (anycpu).  Because of this, XBF was launching in 64-bit mode (which was fine) and since it is running 64-bit, the 64-bit version of IE was being utilized.  Since Adobe hasn't gotten off of their collective butts in the past 6+ months to release a Flash version for 64-bit; therein lies the problem.  So I had to rebuild and redeploy XBF marked as x86 which fixes the problem.  (I have a few other minor updates as well, so those not running x64 benefit as well.)

Summary

I still have a long way to go before I can place my stamp of approval on x64, but so far it's looking pretty good.  I know well enough that some software just isn't going to work, so my expectations are completely in check. Besides, having low expectations makes me smile every time something actually does work. ;-)

Published Tuesday, May 15, 2007 1:26 PM by CorySmith

Comments

No Comments

Anonymous comments are disabled