Welcome to AddressOf.com Sign in | Join | Help

ASP.NET Web Service Tip of the Day

OK, you just built your webservice in ASP.NET and have it working as expected on your local development web server.  Your ready to put it out into the wild and you follow the instructions about changing the webservice namespace from tempuri.org to whatever you want to use.  You xcopy deploy the webservice *.asmx, *.config, and *.dll (bin folder) to your public webserver.  Next, you make sure that the web folder is set as an IIS application.  You browse to the webservice url to make sure everything is working and it responds with a message that says that it's using the tempuri.org namespace and you should change it.  What?  But you did change it, what the h*ll is going on?

Well, the error is completely misleading... it has nothing to do with tempuri.org namespace at all.  The real colprit... you are probably using ASP.NET 1.1 on your machine and development server and on the deployed server, it's set to use ASP.NET 1.0.  Upgrading the public web server to ASP.NET 1.1... all works as expected ;-)

Published Sunday, April 11, 2004 1:09 PM by CorySmith
Filed under: ,

Comments

# re: ASP.NET Web Service Tip of the Day

Thursday, August 24, 2006 2:58 AM by Seuli Maji
Not exactly like that. I have all the version Asp.net 1.1. Still when I change the namespace I did not get my given url. I was getting tempuri.org. Could you please tell me what is the cause behind that? In advance thank you.
Anonymous comments are disabled